eUKhost
HyperSlice
WebhostingUK

York Data Center Network Outage Friday 22nd May 2026 05:30:00


Dear Customers,

We want to inform you that we are currently experiencing a connectivity issue at our York Data Centre. Our network team is actively working to resolve this matter as quickly as possible.

Thank you for your understanding. If you have any questions or need further assistance, please don’t hesitate to reach out.

Regards,

Support Team.

We can confirm that the fibre cable which was severed near Sheffield has now been fully repaired. The repair was carried out by the fibre engineering team following access being granted by National Rail to the affected section of track.

Full service stability was confirmed at 16:50 on 22 May 2026. York DC is now operating with full redundancy restored.

We would like to thank our customers for their patience during this incident.

Update

Connectivity has been restored to the York DC via the Manchester link, and we are currently waiting for confirmation from our upstream provider that full stability has been restored.

The London connection now has engineers on site to repair the fibre. This fibre route runs alongside the railway and, as a result, requires authority from Network Rail before the engineer can access it.

Repairs to the London link are expected to be completed later this afternoon.

UPDATE

We are currently experiencing a network outage affecting services hosted at our York data centre.

Our data centre provider has reported that the primary fibre connection to London has been severed by third-party contractors near Sheffield.

The secondary connection to Manchester is also currently experiencing issues. In both cases, the companies responsible for providing these upstream connections have engineers on site working to restore service.

We will provide updates as further information becomes available.

We apologise for the inconvenience caused.

Dear Customers,

We want to inform you that we are again experiencing a connectivity issue at our York Data Center. Our network team is actively working to resolve this matter as quickly as possible.

Thank you for your understanding. If you have any questions or need further assistance, please don’t hesitate to reach out.

Regards,

Support Team.

UPDATE:

The servers are now responding and services appear to be operational. Our team is still investigating the root cause to ensure full stability.

Thank you for your patience. We will continue to monitor and provide further updates if needed.

UPDATE: Our Data Center engineers are still investigating the issue further. We will share additional updates as soon as more information becomes available.