eUKhost
HyperSlice
WebhostingUK

Phoneline and Chat Friday 5th May 2023 07:00:00


Due to a network issue our phone and chat lines are currently down.

Our engineers are currently investigating the cause and an update will be provided shortly.

We apologies for any inconvenience this may cause.

UPDATE The network issue has now been resolved.

Again, apologies for any inconvenience this issue has caused

UPDATE - Our engineers are still investigating this issue.

Apologies, for any inconvenience caused.